Predicates dont work while following tutorial

Hi everyone, Been following the Faber/Acme/Alice tutorial, all is working up until the point of trying to define a predicate to detect if Alice's GPA is more than 3. I create the Verification Template from the website ui, select my phone from the connections, I get the notification but if the Verification Template includes a predicate an error comes up saying "something went wrong while trying to display the proof reques". Even tried just asking if the GPA is greater than 3 , without anything else in the template to test it, and it still does not work. Tried establishing connection between ACME and Alice again but no luck. Tried without using the connections tab and just scanning the QR code but still no luck. Android application is updated.Is it a known issue? Thanks

Trinsic Studio -> aca-py connection

I can generate a connection invitation in Trinsic Studio, then get the invitation data and I can submit that to aca-py (0.7.0) /connections/receive-invitation. A connection record is created, and in Trinisic Studio, that connection is "Connected". However, on the aca-py side, it is still is "state": "request". I've also called /connections/{connectionid}/accept-invitation, but states on my side never change. Does Trinisic Studio not send a connection response? It seems like my side (aca-py) doesn't know that studio has completed the connection...

How can i use invitation url instead QR

Hi! I am trying Trinsic wallet iOS app on my device. How can I start invitation process by URL instead of scaning QR? My case: 1. I have my own authorization service (OIDC provider + Aries) 2. On device I have my own app with authorization in my athorization service and Trinsic Wallet app 3. I want to start authorize in my app, send authorization request to authorization service, it shows QR in device browser window, but i can't scan it by Trinsic wallet app on the same device. How can i use invitation url instead?

Connection ID doesn't match to the one on the organization dashboard of the Trinsic studio

Hello! We are developing our app using Trinsic API and have run into the following situation. So we created a connection with an organization using the Trinsic credentials api `createConnection` and the API key. It returns an `invitationUrl`, using this url we called the Trinsic wallet api `accepInvitation`. It was successful and I can see the wallet name on the organization’s dashboard of the Trinsic studio. To get the connectionId, we used the Trinsic wallet api `listConnections` but the returned connectionId is different from the one on the dashboard. With the connectionId obtained from the API we can not issue a credential to it with the API. Why is there a mismatch? How can we obtain the Id that is displayed on the dashboard?

Cannot "present" proof_request with "non_revoked" field

Hi, I'm having trouble presenting attributes for proof requests on Trinsic if my proof requests include a "non_revoked" field. Context: I'm sending a proof requests via the latest version of ACA-Py using the "/present-proof/send-request" route, as per the Aries RFC 0037: Present Proof Protocol 1.0. I can view and present attributes for proof requests on Trinsic if they are send without a "non_revoked" field. However, when I add the "non_revoked" field, and click to "present" I am prompted by "Something went wrong" (after about 30 seconds). From what I've read, proof requests of this form (with a "non_revoked" field) are supported by Trinsic through Aries RFC 0037. Am I wrong? Or, alternatively, is there something I am missing about how to carry out these proof requests? Ultimately, I want to make sure that attributes from credentials that have been revoked cannot be used in presentations. Thanks!

Organizatio or Tenant?

It is kind of confusing. What is the difference between an Organization and a Tenant. If you go to this Page: https://docs.trinsic.id/docs/organizations and then click the link at the bottom you get directed to the Create Tenant page of the Provider API. In this sentence, the word Tenant is used in a different context: Organizations in the Trinsic platform are software programs capable of issuing and verifying credentials running on a dedicated tenant in Trinsic's secure cloud environment. This sentence is also on the page linked above. So have Organizations been renamed to Tenants?

Key management

Hi, we would like to get better understanding of key management in cloud and mobile wallets. How are keys stored in cloud wallet? How are keys secured against misuse or database breach? Do you make use of secure multiparty computation? How are keys stored in (full) mobile wallet - are you making use of secure enclaves? What is revocation mechanism, if there's any, in case user lost their device of forgot their password?

Rejected proof presentation request - verification state doesn't change

When I create proof presentation request and reject it in wallet, verification status isn't changed - I would expect it to change to `Rejected` status, but it stays `Requested`. Here's my code: ``` const predicatePolicies = [{ policyName: AGE, attributeName: AGE, predicateType: ">=", predicateValue: legalDrinkingAge, restrictions: [{ value: { attributeName: AGE, attributeValue: String(legalDrinkingAge) } }] }]; let verification = await this.credentialsClient.sendVerificationFromParameters(connectionId, { name: "Verification Name", version: "1.0", predicates: predicatePolicies, }); const verificationId = verification.verificationId!; verification = await this.credentialsClient.getVerification(verificationId); while (verification.state! !== 'Accepted' && verification.state! !== 'Rejected') { await new Promise(resolve => setTimeout(resolve, 1000)); verification = await this.credentialsClient.getVerification(verificationId); } ``` The `while` loop never breaks because `verification.state` remains set to `Requested`. Am I doing something wrong? Or is it possible that it is bug?

Obtain aries invitation

Is it possible to create connection and programmatically obtain Aries-compatible invitation (JSON-LD with connection details)? The purpose here is to establish connection with other Sovrin compatible wallets, especially our custom one. The `invitation` field in response from connection create endpoint contains most data required and I am able to compose required file, but it feels "hacky". Thanks in advance!

Receiving error with cloud wallet connectionless verification using params on nodejs

Error: {"error":"Unhandled exception: Object reference not set to an instance of an object.","errorType":"NullReferenceException"} at new RestError (/workspace/node_modules/@azure/ms-rest-js/dist/msRest.node.js:2434:28) at /workspace/node_modules/@azure/ms-rest-js/dist/msRest.node.js:3587:37 at process._tickCallback (internal/process/next_tick.js:68:7)